diff src/configure.ac @ 30998:10aa54743543 v9.0.0834

patch 9.0.0834: warning for missing return type Commit: https://github.com/vim/vim/commit/f8ea10677d007befbb6f24cd20f35c3bf71c1296 Author: Sam James <sam@gentoo.org> Date: Sat Nov 5 15:13:50 2022 +0000 patch 9.0.0834: warning for missing return type Problem: Warning for missing return type. Solution: Add "int". (San James, closes https://github.com/vim/vim/issues/11496)
author Bram Moolenaar <Bram@vim.org>
date Sat, 05 Nov 2022 16:15:03 +0100
parents 2295ee9c025d
children aaaf695aeb6c
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -3654,7 +3654,7 @@ dnl check if struct sigcontext is define
 AC_MSG_CHECKING(for struct sigcontext)
 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([
 #include <signal.h>
-test_sig()
+int test_sig()
 {
     struct sigcontext *scont;
     scont = (struct sigcontext *)0;