diff src/configure.ac @ 33940:f60c0fe7cae4 v9.0.2166

patch 9.0.2166: Memory leak in Configure Script when checking GTK Commit: https://github.com/vim/vim/commit/549f8c0b4ebe47168c98f46c8b62b1eb33da7c9c Author: Zdenek Dohnal <zdohnal@redhat.com> Date: Thu Dec 14 20:22:49 2023 +0100 patch 9.0.2166: Memory leak in Configure Script when checking GTK Problem: Memory leak in Configure Script when checking GTK Solution: Free the allocated memory If the memory is not freed, GTK GUI VIM cannot be build with address sanitizer for debugging purposes - configure script will report missing GTK, because the testing file compilation fails due reported memory leak. closes: #13672 Signed-off-by: Zdenek Dohnal <zdohnal@redhat.com> Signed-off-by: Christian Brabandt <cb@256bit.org>
author Christian Brabandt <cb@256bit.org>
date Thu, 14 Dec 2023 20:30:05 +0100
parents cdf91c682acf
children dd5023389a98
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2700,9 +2700,12 @@ system ("touch conf.gtktest");
 tmp_version = g_strdup("$min_gtk_version");
 if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
    printf("%s, bad version string\n", "$min_gtk_version");
+   g_free(tmp_version);
    exit(1);
  }
 
+g_free(tmp_version);
+
 if ((gtk_major_version > major) ||
     ((gtk_major_version == major) && (gtk_minor_version > minor)) ||
     ((gtk_major_version == major) && (gtk_minor_version == minor) &&