diff src/configure.ac @ 14447:f103c66ea515 v8.1.0237

patch 8.1.0237: Ruby on Cygwin doesn't always work commit https://github.com/vim/vim/commit/87ea64ca965ca00b3e72776c39355964293f2ace Author: Bram Moolenaar <Bram@vim.org> Date: Sat Aug 4 15:13:34 2018 +0200 patch 8.1.0237: Ruby on Cygwin doesn't always work Problem: Ruby on Cygwin doesn't always work. Solution: Use LIBRUBY_SO if LIBRUBY_ALIASES isn't set. (Ken Takata)
author Christian Brabandt <cb@256bit.org>
date Sat, 04 Aug 2018 15:15:05 +0200
parents 6b3ad2849e24
children cf33c47d66aa
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1956,6 +1956,9 @@ if test "$enable_rubyinterp" = "yes" -o 
 	AC_DEFINE(FEAT_RUBY)
 	if test "$enable_rubyinterp" = "dynamic"; then
 	  libruby_soname=`$vi_cv_path_ruby -r rbconfig -e "puts $ruby_rbconfig::CONFIG[['LIBRUBY_ALIASES']].split[[0]]"`
+	  if test -z "$libruby_soname"; then
+	    libruby_soname=`$vi_cv_path_ruby -r rbconfig -e "puts $ruby_rbconfig::CONFIG[['LIBRUBY_SO']]"`
+	  fi
 	  AC_DEFINE(DYNAMIC_RUBY)
 	  RUBY_CFLAGS="-DDYNAMIC_RUBY_DLL=\\\"$libruby_soname\\\" -DDYNAMIC_RUBY_VER=$rubyversion $RUBY_CFLAGS"
 	  RUBY_LIBS=