diff src/configure.ac @ 11370:e11d5966b822 v8.0.0570

patch 8.0.0570: can't run make with several jobs commit https://github.com/vim/vim/commit/c03944151fec2d5469746642a949c8fcb5a744a8 Author: Bram Moolenaar <Bram@vim.org> Date: Thu Apr 20 20:20:23 2017 +0200 patch 8.0.0570: can't run make with several jobs Problem: Can't run make with several jobs, creating directories has a race condition. Solution: Use the MKDIR_P autoconf mechanism. (Eric N. Vander Weele, closes #1639)
author Christian Brabandt <cb@256bit.org>
date Thu, 20 Apr 2017 20:30:04 +0200
parents 0895f142cac3
children 3f399c28e4af
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -11,12 +11,13 @@ AC_DEFINE(UNIX)
 AC_PROG_MAKE_SET
 
 dnl Checks for programs.
-AC_PROG_CC	dnl required by almost everything
-AC_PROG_CPP	dnl required by header file checks
-AC_PROGRAM_EGREP dnl required by AC_EGREP_CPP
-AC_PROG_FGREP	dnl finds working grep -F
-AC_ISC_POSIX	dnl required by AC_C_CROSS
-AC_PROG_AWK	dnl required for "make html" in ../doc
+AC_PROG_CC		dnl required by almost everything
+AC_PROG_CPP		dnl required by header file checks
+AC_PROGRAM_EGREP	dnl required by AC_EGREP_CPP
+AC_PROG_FGREP		dnl finds working grep -F
+AC_ISC_POSIX		dnl required by AC_C_CROSS
+AC_PROG_AWK		dnl required for "make html" in ../doc
+AC_PROG_MKDIR_P		dnl portable "mkdir -p", also works in parallel
 
 dnl Don't strip if we don't have it
 AC_CHECK_PROG(STRIP, strip, strip, :)