diff src/configure.ac @ 24864:db4afe19285d v8.2.2970

patch 8.2.2970: Python configure check uses deprecated command Commit: https://github.com/vim/vim/commit/31e299c08f250b126b2c2c0ecce12ee563b70fdc Author: Zdenek Dohnal <zdohnal@redhat.com> Date: Thu Jun 10 18:50:55 2021 +0200 patch 8.2.2970: Python configure check uses deprecated command Problem: Python configure check uses deprecated command. Solution: Use sysconfig instead of distutils if possible. (Zdenek Dohnal, closes #8354)
author Bram Moolenaar <Bram@vim.org>
date Thu, 10 Jun 2021 19:00:03 +0200
parents ae30a87aafd3
children 7e9e53a0368f
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1487,7 +1487,10 @@ if test "$enable_python3interp" = "yes" 
       [
        vi_cv_path_python3_conf=
        config_dir="config-${vi_cv_var_python3_version}${vi_cv_var_python3_abiflags}"
-       d=`${vi_cv_path_python3} -c "import distutils.sysconfig; print(distutils.sysconfig.get_config_var('LIBPL'))"`
+       d=`${vi_cv_path_python3} -c "import sysconfig; print(sysconfig.get_config_var('LIBPL'))" 2> /dev/null`
+       if test "x$d" = "x"; then
+         d=`${vi_cv_path_python3} -c "import distutils.sysconfig; print(distutils.sysconfig.get_config_var('LIBPL'))"`
+       fi
        if test -d "$d" && test -f "$d/config.c"; then
          vi_cv_path_python3_conf="$d"
        else