diff src/configure.ac @ 14718:cf33c47d66aa v8.1.0371

patch 8.1.0371: argument types for select() may be wrong commit https://github.com/vim/vim/commit/643b6140873e0e6f297df0cbca11bc1ea1f21925 Author: Bram Moolenaar <Bram@vim.org> Date: Wed Sep 12 20:29:09 2018 +0200 patch 8.1.0371: argument types for select() may be wrong Problem: Argument types for select() may be wrong. Solution: Use a configure macro. (Tobias Ulmer)
author Christian Brabandt <cb@256bit.org>
date Wed, 12 Sep 2018 20:30:05 +0200
parents f103c66ea515
children 2c72fa16aa70
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -3721,6 +3721,7 @@ AC_CHECK_FUNCS(fchdir fchown fchmod fsyn
 	sigprocmask sigvec strcasecmp strerror strftime stricmp strncasecmp \
 	strnicmp strpbrk strtol tgetent towlower towupper iswupper \
 	usleep utime utimes mblen ftruncate unsetenv)
+AC_FUNC_SELECT_ARGTYPES
 AC_FUNC_FSEEKO
 
 dnl define _LARGE_FILES, _FILE_OFFSET_BITS and _LARGEFILE_SOURCE when