diff src/configure.ac @ 12714:baf88919c791 v8.0.1235

patch 8.0.1235: cannot disable the terminal feature in a huge build commit https://github.com/vim/vim/commit/ef83956e1e67736b4c6b886d897b74f022622a74 Author: Bram Moolenaar <Bram@vim.org> Date: Sat Oct 28 20:28:23 2017 +0200 patch 8.0.1235: cannot disable the terminal feature in a huge build Problem: Cannot disable the terminal feature in a huge build. (lindhobe) Solution: Adjust the autoconf check. (Kazunobu Kuriyama, closes https://github.com/vim/vim/issues/2242)
author Christian Brabandt <cb@256bit.org>
date Sat, 28 Oct 2017 20:30:05 +0200
parents 12f4408c7f69
children 351cf7c67bbe
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2035,7 +2035,7 @@ fi
 AC_MSG_CHECKING(--enable-terminal argument)
 AC_ARG_ENABLE(terminal,
 	[  --enable-terminal       Enable terminal emulation support.],
-	[enable_terminal="yes"], [enable_terminal="auto"])
+	, [enable_terminal="auto"])
 if test "$enable_terminal" = "yes" || test "$enable_terminal" = "auto" -a "x$features" = "xhuge" ; then
   if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
     AC_MSG_RESULT([cannot use terminal emulator with tiny or small features])