diff src/configure.in @ 5280:ba37e955913e v7.4b.016

updated for version 7.4b.016 Problem: Ruby detection fails on Fedora 19. Solution: Use one way to get the Ruby version. (Michael Henry)
author Bram Moolenaar <bram@vim.org>
date Wed, 07 Aug 2013 15:22:23 +0200
parents da95a7f1d5a8
children 31c9acfeda8f
line wrap: on
line diff
--- a/src/configure.in
+++ b/src/configure.in
@@ -1659,6 +1659,9 @@ if test "$enable_rubyinterp" = "yes" -o 
           RUBY_CFLAGS="$RUBY_CFLAGS -I$rubyhdrdir/$rubyarch"
         fi
         rubyversion=`$vi_cv_path_ruby -r rbconfig -e "print $ruby_rbconfig::CONFIG[['ruby_version']].gsub(/\./, '')[[0,2]]"`
+	if test "X$rubyversion" = "X"; then
+	  rubyversion=`$vi_cv_path_ruby -e "print ((VERSION rescue RUBY_VERSION)).gsub(/\./, '')[[0,2]]"`
+	fi
         RUBY_CFLAGS="$RUBY_CFLAGS -DRUBY_VERSION=$rubyversion"
 	rubylibs=`$vi_cv_path_ruby -r rbconfig -e "print $ruby_rbconfig::CONFIG[['LIBS']]"`
 	if test "X$rubylibs" != "X"; then