diff src/configure.ac @ 16289:b4c7e026685c v8.1.1149

patch 8.1.1149: building desktop files fails with older msgfmt commit https://github.com/vim/vim/commit/26096cc96fc402db45948b3b662a380281585649 Author: Bram Moolenaar <Bram@vim.org> Date: Thu Apr 11 15:25:40 2019 +0200 patch 8.1.1149: building desktop files fails with older msgfmt Problem: Building desktop files fails with older msgfmt. Solution: Add autoconf check. Avoid always building the desktop files.
author Bram Moolenaar <Bram@vim.org>
date Thu, 11 Apr 2019 15:30:03 +0200
parents a6ca8cf07a98
children c1dca26a6949
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4298,6 +4298,15 @@ if test "$enable_nls" = "yes"; then
 		[++_nl_msg_cat_cntr;],
 		AC_MSG_RESULT([yes]); AC_DEFINE(HAVE_NL_MSG_CAT_CNTR),
 		AC_MSG_RESULT([no]))
+      AC_MSG_CHECKING([if msgfmt supports --desktop])
+      MSGFMT_DESKTOP=
+      if "$MSGFMT" --help | grep -e '--desktop' >/dev/null; then
+	AC_MSG_RESULT([yes])
+	MSGFMT_DESKTOP="gvim.desktop vim.desktop"
+      else
+	AC_MSG_RESULT([no])
+      fi
+      AC_SUBST(MSGFMT_DESKTOP)
     fi
   else
     AC_MSG_RESULT([no "po/Makefile" - disabled]);