diff src/configure.ac @ 32238:b2cce50602ca v9.0.1450

patch 9.0.1450: MacOS: building fails if clock_gettime() is not available Commit: https://github.com/vim/vim/commit/08210f8def4886b0cd04dd4bbebed719f0512315 Author: Bram Moolenaar <Bram@vim.org> Date: Thu Apr 13 19:15:54 2023 +0100 patch 9.0.1450: MacOS: building fails if clock_gettime() is not available Problem: MacOS: building fails if clock_gettime() is not available. Solution: Add a configure check for clock_gettime(). (closes https://github.com/vim/vim/issues/12242)
author Bram Moolenaar <Bram@vim.org>
date Thu, 13 Apr 2023 20:30:03 +0200
parents ac2f07ae1957
children a182764faa18
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -3709,7 +3709,8 @@ AC_CHECK_FUNCS(fchdir fchown fchmod fsyn
 	getpgid setpgid setsid sigaltstack sigstack sigset sigsetjmp sigaction \
 	sigprocmask sigvec strcasecmp strcoll strerror strftime stricmp strncasecmp \
 	strnicmp strpbrk strptime strtol tgetent towlower towupper iswupper \
-	tzset usleep utime utimes mblen ftruncate unsetenv posix_openpt)
+	tzset usleep utime utimes mblen ftruncate unsetenv posix_openpt \
+	clock_gettime)
 AC_FUNC_SELECT_ARGTYPES
 AC_FUNC_FSEEKO