diff src/configure.ac @ 11405:b164223c0119 v8.0.0587

patch 8.0.0587: configure check for return value of tgetent skipped commit https://github.com/vim/vim/commit/696cbd224b4f78b99b8fc34538867303a8a922fc Author: Bram Moolenaar <Bram@vim.org> Date: Fri Apr 28 15:45:46 2017 +0200 patch 8.0.0587: configure check for return value of tgetent skipped Problem: Configure check for return value of tgetent is skipped. Solution: Always perform the check. (Marvin Schmidt, closes https://github.com/vim/vim/issues/1664)
author Christian Brabandt <cb@256bit.org>
date Fri, 28 Apr 2017 16:00:06 +0200
parents 3f399c28e4af
children 621e41f6dcc2
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -3355,10 +3355,9 @@ if test "x$vim_cv_terminfo" = "xyes" ; t
   AC_DEFINE(TERMINFO)
 fi
 
-if test "x$olibs" != "x$LIBS"; then
-  AC_CACHE_CHECK([what tgetent() returns for an unknown terminal], [vim_cv_tgent],
-    [
-      AC_RUN_IFELSE([AC_LANG_SOURCE([[
+AC_CACHE_CHECK([what tgetent() returns for an unknown terminal], [vim_cv_tgent],
+  [
+    AC_RUN_IFELSE([AC_LANG_SOURCE([[
 #include "confdefs.h"
 #ifdef HAVE_TERMCAP_H
 # include <termcap.h>
@@ -3369,18 +3368,17 @@ if test "x$olibs" != "x$LIBS"; then
 #endif
 main()
 {char s[10000]; int res = tgetent(s, "thisterminaldoesnotexist"); exit(res != 0); }
-      ]])],[
-	vim_cv_tgent=zero
-      ],[
-	vim_cv_tgent=non-zero
-      ],[
-	AC_MSG_ERROR(failed to compile test program.)
-      ])
+    ]])],[
+      vim_cv_tgent=zero
+    ],[
+      vim_cv_tgent=non-zero
+    ],[
+      AC_MSG_ERROR(failed to compile test program.)
     ])
-  
-  if test "x$vim_cv_tgent" = "xzero" ; then
-    AC_DEFINE(TGETENT_ZERO_ERR, 0)
-  fi
+  ])
+
+if test "x$vim_cv_tgent" = "xzero" ; then
+  AC_DEFINE(TGETENT_ZERO_ERR, 0)
 fi
 
 AC_MSG_CHECKING(whether termcap.h contains ospeed)