diff src/configure.ac @ 32228:ac2f07ae1957 v9.0.1445

patch 9.0.1445: openSUSE: configure doesn't find the Motif library Commit: https://github.com/vim/vim/commit/01967f5b1042b375b38098eceaf31671902c8dbb Author: Bram Moolenaar <Bram@vim.org> Date: Wed Apr 12 16:24:03 2023 +0100 patch 9.0.1445: openSUSE: configure doesn't find the Motif library Problem: openSUSE: configure doesn't find the Motif library. (Tony Mechelynck) Solution: Also search in /usr/lib64.
author Bram Moolenaar <Bram@vim.org>
date Wed, 12 Apr 2023 17:30:06 +0200
parents 8f4aa24617c2
children b2cce50602ca
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2976,8 +2976,9 @@ if test -z "$SKIP_MOTIF"; then
     dnl Ubuntu has libXm.so in /usr/lib/i386-linux-gnu and elsewhere.  The
     dnl linker will figure out which one to use, we only check if one exists.
     dnl Cygwin uses the .dll.a extension.
+    dnl OpenSUSE appears to use /usr/lib64.
     AC_MSG_CHECKING(for location of Motif GUI libs)
-    gui_libs="`echo $x_libraries|sed 's%/[^/][^/]*$%%'` `echo "$gui_XXX" | sed s/XXX/lib/g` /usr/lib/i386-linux-gnu /usr/lib/x86_64-linux-gnu `echo "$GUI_INC_LOC" | sed s/include/lib/` $GUI_LIB_LOC"
+    gui_libs="`echo $x_libraries|sed 's%/[^/][^/]*$%%'` `echo "$gui_XXX" | sed s/XXX/lib/g` /usr/lib64 /usr/lib/i386-linux-gnu /usr/lib/x86_64-linux-gnu `echo "$GUI_INC_LOC" | sed s/include/lib/` $GUI_LIB_LOC"
     GUI_LIB_LOC=
     for try in $gui_libs; do
       for libtry in "$try"/libXm.a "$try"/libXm.dll.a "$try"/libXm.so* "$try"/libXm.sl "$try"/libXm.dylib; do
@@ -2987,8 +2988,10 @@ if test -z "$SKIP_MOTIF"; then
       done
     done
     if test -n "$GUI_LIB_LOC"; then
-      dnl Remove /usr/lib, it causes trouble on some systems
+      dnl Remove /usr/lib, it causes trouble on some systems.
+      dnl For consistency also remove other standard lib directories.
       if test "$GUI_LIB_LOC" = /usr/lib \
+	   -o "$GUI_LIB_LOC" = /usr/lib64 \
 	   -o "$GUI_LIB_LOC" = /usr/lib/i386-linux-gnu \
 	   -o "$GUI_LIB_LOC" = /usr/lib/x86_64-linux-gnu; then
 	GUI_LIB_LOC=