diff src/configure.in @ 4895:8b46c37c4b84 v7.3.1193

updated for version 7.3.1193 Problem: fail_if_missing not used for Python 3. Solution: Give an error when Python 3 can't be configured. (Andrei Olsen)
author Bram Moolenaar <bram@vim.org>
date Fri, 14 Jun 2013 21:22:39 +0200
parents ed47632fd149
children b89aa3374b7f
line wrap: on
line diff
--- a/src/configure.in
+++ b/src/configure.in
@@ -1229,6 +1229,9 @@ eof
       AC_MSG_RESULT(too old)
     fi
   fi
+  if test "$fail_if_missing" = "yes" -a "$python3_ok" != "yes"; then
+    AC_MSG_ERROR([could not configure python3])
+  fi
 fi
 
 AC_SUBST(PYTHON3_CONFDIR)