diff src/configure.ac @ 34543:748a8a413816 v9.1.0173

patch 9.1.0173: msgfmt ver. 0.22 forcibly converts text to UTF-8 Commit: https://github.com/vim/vim/commit/e498cafe74e9073a9f8134f04c22b61d7bc68894 Author: RestorerZ <restorer@mail2k.ru> Date: Tue Mar 12 22:11:36 2024 +0100 patch 9.1.0173: msgfmt ver. 0.22 forcibly converts text to UTF-8 Problem: msgfmt ver. 0.22 forcibly converts text to UTF-8 Solution: use '--no-convert' if msgfmt supports it. Add a configure check for the msgfmt version (RestorerZ). closes: #14163 Co-authored-by: Christian Brabandt <cb@256bit.org> Signed-off-by: RestorerZ <restorer@mail2k.ru> Signed-off-by: Christian Brabandt <cb@256bit.org>
author Christian Brabandt <cb@256bit.org>
date Tue, 12 Mar 2024 22:30:03 +0100
parents dd5023389a98
children a843afce8fcf
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4523,6 +4523,15 @@ if test "$enable_nls" = "yes"; then
 	AC_MSG_RESULT([no])
       fi
       AC_SUBST(MSGFMT_DESKTOP)
+      AC_MSG_CHECKING([if msgfmt supports --no-convert])
+      if "$MSGFMT" --help | grep -q --  '--no-convert' >/dev/null; then
+        AC_MSG_RESULT([yes])
+        MSGFMTCMD="OLD_PO_FILE_INPUT=yes msgfmt --no-convert -v"
+      else
+        AC_MSG_RESULT([no])
+        MSGFMTCMD="OLD_PO_FILE_INPUT=yes msgfmt -v"
+      fi
+      AC_SUBST(MSGFMTCMD)
     fi
   else
     AC_MSG_RESULT([no "po/Makefile" - disabled]);