diff src/configure.in @ 5421:739074bdceb8 v7.4.061

updated for version 7.4.061 Problem: Availability macros configure check in wrong place. Solution: Also check when not using Darwin. Remove version check.
author Bram Moolenaar <bram@vim.org>
date Sun, 03 Nov 2013 00:41:00 +0100
parents 38a755adc580
children d59a0b8e5584
line wrap: on
line diff
--- a/src/configure.in
+++ b/src/configure.in
@@ -206,10 +206,6 @@ if test "`(uname) 2>/dev/null`" = Darwin
     dnl TODO: use -arch i386 on Intel machines
     CPPFLAGS="$CPPFLAGS -DMACOS_X_UNIX -no-cpp-precomp"
 
-    dnl Mac OS X 10.9+ no longer include AvailabilityMacros.h in Carbon
-    dnl so we need to include it to have access to version macros.
-    AC_CHECK_HEADER(AvailabilityMacros.h, [AC_DEFINE(HAVE_AVAILABILITYMACROS_H, 1, [ Define if we have AvailabilityMacros.h on Mac OS X ])])
-
     dnl If Carbon is found, assume we don't want X11
     dnl unless it was specifically asked for (--with-x)
     dnl or Motif, Athena or GTK GUI is used.
@@ -232,6 +228,10 @@ else
   AC_MSG_RESULT(no)
 fi
 
+dnl Mac OS X 10.9+ no longer include AvailabilityMacros.h in Carbon
+dnl so we need to include it to have access to version macros.
+AC_CHECK_HEADER(AvailabilityMacros.h, HAVE_AVAILABILITYMACROS_H=1)
+
 AC_SUBST(OS_EXTRA_SRC)
 AC_SUBST(OS_EXTRA_OBJ)