diff src/configure.in @ 6651:7026d6f3367f v7.4.650

updated for version 7.4.650 Problem: Configure check may fail because the dl library is not used. Solution: Put "-ldl" in LIBS rather than LDFLAGS. (Oazki Kiichi)
author Bram Moolenaar <bram@vim.org>
date Thu, 05 Mar 2015 16:47:20 +0100
parents 3421b24e419c
children 692bc2c52002
line wrap: on
line diff
--- a/src/configure.in
+++ b/src/configure.in
@@ -1451,9 +1451,9 @@ if test "$python_ok" = yes && test "$pyt
   AC_MSG_CHECKING(whether we can do without RTLD_GLOBAL for Python)
   cflags_save=$CFLAGS
   CFLAGS="$CFLAGS $PYTHON_CFLAGS"
-  ldflags_save=$LDFLAGS
+  libs_save=$LIBS
   dnl -ldl must go first to make this work on Archlinux (Roland Puntaier)
-  LDFLAGS="-ldl $LDFLAGS"
+  LIBS="-ldl $LIBS"
   AC_RUN_IFELSE([AC_LANG_SOURCE([
     #include <dlfcn.h>
     /* If this program fails, then RTLD_GLOBAL is needed.
@@ -1491,14 +1491,14 @@ if test "$python_ok" = yes && test "$pyt
     [AC_MSG_RESULT(yes);AC_DEFINE(PY_NO_RTLD_GLOBAL)], [AC_MSG_RESULT(no)])
 
   CFLAGS=$cflags_save
-  LDFLAGS=$ldflags_save
+  LIBS=$libs_save
 
   AC_MSG_CHECKING(whether we can do without RTLD_GLOBAL for Python3)
   cflags_save=$CFLAGS
   CFLAGS="$CFLAGS $PYTHON3_CFLAGS"
-  ldflags_save=$LDFLAGS
+  libs_save=$LIBS
   dnl -ldl must go first to make this work on Archlinux (Roland Puntaier)
-  LDFLAGS="-ldl $LDFLAGS"
+  LIBS="-ldl $LIBS"
   AC_RUN_IFELSE([AC_LANG_SOURCE([
     #include <dlfcn.h>
     #include <wchar.h>
@@ -1537,7 +1537,7 @@ if test "$python_ok" = yes && test "$pyt
     [AC_MSG_RESULT(yes);AC_DEFINE(PY3_NO_RTLD_GLOBAL)], [AC_MSG_RESULT(no)])
 
   CFLAGS=$cflags_save
-  LDFLAGS=$ldflags_save
+  LIBS=$libs_save
 
   PYTHON_SRC="if_python.c"
   PYTHON_OBJ="objects/if_python.o"