diff src/configure.ac @ 14401:6b3ad2849e24 v8.1.0215

patch 8.1.0215: no error if configure --with-x cannot configure X commit https://github.com/vim/vim/commit/d2a054910bf8f0888fac81e46a64a22dd4a763b5 Author: Bram Moolenaar <Bram@vim.org> Date: Fri Jul 27 22:35:15 2018 +0200 patch 8.1.0215: no error if configure --with-x cannot configure X Problem: No error if configure --with-x cannot configure X. Solution: Check that when --with-x is used X can be configured.
author Christian Brabandt <cb@256bit.org>
date Fri, 27 Jul 2018 22:45:05 +0200
parents e4d5726e1678
children f103c66ea515
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -72,6 +72,9 @@ AC_ARG_ENABLE(fail_if_missing,
 	[fail_if_missing="no"])
 AC_MSG_RESULT($fail_if_missing)
 
+dnl Keep original value to check later.
+with_x_arg="$with_x"
+
 dnl Set default value for CFLAGS if none is defined or it's empty
 if test -z "$CFLAGS"; then
   CFLAGS="-O"
@@ -2283,6 +2286,11 @@ else
   fi
 fi
 
+dnl Check if --with-x was given but it doesn't work.
+if test "x$with_x" = xno -a "x$with_x_arg" = xyes; then
+    AC_MSG_ERROR([could not configure X])
+fi
+
 test "x$with_x" = xno -a "x$MACOS_X" != "xyes" -a "x$QNX" != "xyes" && enable_gui=no
 
 AC_MSG_CHECKING(--enable-gui argument)