diff src/configure.ac @ 28321:58ecd574b132 v8.2.4686

patch 8.2.4686: configure doesn't find the Motif library with Cygwin Commit: https://github.com/vim/vim/commit/b471690fad5f40f74aca488b13669641fb2b9de1 Author: Kelvin Lee <kiyolee@gmail.com> Date: Mon Apr 4 17:20:01 2022 +0100 patch 8.2.4686: configure doesn't find the Motif library with Cygwin Problem: Configure doesn't find the Motif library with Cygwin. Solution: Check for libXm.dll.a. (Kelvin Lee, closes https://github.com/vim/vim/issues/10077)
author Bram Moolenaar <Bram@vim.org>
date Mon, 04 Apr 2022 18:30:03 +0200
parents 6312a35b254a
children b90bca860b5a
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2965,11 +2965,12 @@ if test -z "$SKIP_MOTIF"; then
 
     dnl Ubuntu has libXm.so in /usr/lib/i386-linux-gnu and elsewhere.  The
     dnl linker will figure out which one to use, we only check if one exists.
+    dnl Cygwin uses the .dll.a extension.
     AC_MSG_CHECKING(for location of Motif GUI libs)
     gui_libs="`echo $x_libraries|sed 's%/[^/][^/]*$%%'` `echo "$gui_XXX" | sed s/XXX/lib/g` /usr/lib/i386-linux-gnu /usr/lib/x86_64-linux-gnu `echo "$GUI_INC_LOC" | sed s/include/lib/` $GUI_LIB_LOC"
     GUI_LIB_LOC=
     for try in $gui_libs; do
-      for libtry in "$try"/libXm.a "$try"/libXm.so* "$try"/libXm.sl "$try"/libXm.dylib; do
+      for libtry in "$try"/libXm.a "$try"/libXm.dll.a "$try"/libXm.so* "$try"/libXm.sl "$try"/libXm.dylib; do
 	if test -f "$libtry"; then
 	  GUI_LIB_LOC=$try
 	fi