diff src/configure.ac @ 23116:55f8b7da27f3 v8.2.2104

patch 8.2.2104: build problem with Ruby 2.7 Commit: https://github.com/vim/vim/commit/d5a986f460019a924627d79350552f446505cffb Author: Bram Moolenaar <Bram@vim.org> Date: Sun Dec 6 21:11:31 2020 +0100 patch 8.2.2104: build problem with Ruby 2.7 Problem: Build problem with Ruby 2.7. Solution: Adjust function declarations. (Ozaki Kiichi, closes https://github.com/vim/vim/issues/7430)
author Bram Moolenaar <Bram@vim.org>
date Sun, 06 Dec 2020 21:15:05 +0100
parents d020ba29f111
children 96a72f1f6c0c
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1965,8 +1965,7 @@ if test "$enable_rubyinterp" = "yes" -o 
 	librubyarg=`$vi_cv_path_ruby -r rbconfig -e "print $ruby_rbconfig.expand($ruby_rbconfig::CONFIG[['LIBRUBYARG']])"`
 	librubya=`$vi_cv_path_ruby -r rbconfig -e "print $ruby_rbconfig.expand($ruby_rbconfig::CONFIG[['LIBRUBY_A']])"`
 	rubylibdir=`$vi_cv_path_ruby -r rbconfig -e "print $ruby_rbconfig.expand($ruby_rbconfig::CONFIG[['libdir']])"`
-	if test -f "$rubylibdir/$librubya"; then
-	  librubyarg="$librubyarg"
+	if test -f "$rubylibdir/$librubya" || expr "$librubyarg" : "-lruby"; then
 	  RUBY_LIBS="$RUBY_LIBS -L$rubylibdir"
 	elif test "$librubyarg" = "libruby.a"; then
 	  dnl required on Mac OS 10.3 where libruby.a doesn't exist