diff src/configure.ac @ 12555:55257baece9a v8.0.1156

patch 8.0.1156: trouble from removing one -W argument from Perl CFLAGS commit https://github.com/vim/vim/commit/1ec96c926974208bd47710384c8202c47d0752d0 Author: Bram Moolenaar <Bram@vim.org> Date: Wed Sep 27 21:42:08 2017 +0200 patch 8.0.1156: trouble from removing one -W argument from Perl CFLAGS Problem: Removing one -W argument from Perl CFLAGS may cause trouble. Solution: Remove all -W flags. (Christian Brabandt)
author Christian Brabandt <cb@256bit.org>
date Wed, 27 Sep 2017 21:45:04 +0200
parents ebadf868ac4b
children 12f4408c7f69
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1006,10 +1006,13 @@ if test "$enable_perlinterp" = "yes" -o 
       dnl Remove "-fno-something", it breaks using cproto.
       dnl Remove "-fdebug-prefix-map", it isn't supported by clang.
       dnl Remove "FORTIFY_SOURCE", it will be defined twice.
+      dnl remove -pipe and -Wxxx, it confuses cproto
       perlcppflags=`$vi_cv_path_perl -Mlib=$srcdir -MExtUtils::Embed \
 		-e 'ccflags;perl_inc;print"\n"' | sed -e 's/-fno[[^ ]]*//' \
 		-e 's/-fdebug-prefix-map[[^ ]]*//g' \
-		-e 's/\(-Wp,\)\?-D_FORTIFY_SOURCE=.//g'`
+		-e 's/-pipe //' \
+		-e 's/-W[[^ ]]*//g' \
+		-e 's/-D_FORTIFY_SOURCE=.//g'`
       dnl Remove "-lc", it breaks on FreeBSD when using "-pthread".
       perllibs=`cd $srcdir; $vi_cv_path_perl -MExtUtils::Embed -e 'ldopts' | \
 		sed -e '/Warning/d' -e '/Note (probably harmless)/d' \
@@ -1037,8 +1040,7 @@ if test "$enable_perlinterp" = "yes" -o 
       LDFLAGS=$ldflags_save
       if test $perl_ok = yes; then
 	if test "X$perlcppflags" != "X"; then
-	  dnl remove -pipe and -Wxxx, it confuses cproto
-	  PERL_CFLAGS=`echo "$perlcppflags" | sed -e 's/-pipe //' -e 's/-W[[^ ]]*//'`
+	  PERL_CFLAGS=$perlcppflags
 	fi
 	if test "X$perlldflags" != "X"; then
 	  if test "X`echo \"$LDFLAGS\" | $FGREP -e \"$perlldflags\"`" = "X"; then