diff src/configure.ac @ 15205:54d2905bd5ab v8.1.0612

patch 8.1.0612: cannot use two global runtime dirs with configure commit https://github.com/vim/vim/commit/9d302ad4e31b4e20ce0b3af700f43edb6f5e6036 Author: Bram Moolenaar <Bram@vim.org> Date: Fri Dec 21 11:48:51 2018 +0100 patch 8.1.0612: cannot use two global runtime dirs with configure Problem: Cannot use two global runtime dirs with configure. Solution: Support a comma in --with-global-runtime. (James McCoy, closes #3704)
author Bram Moolenaar <Bram@vim.org>
date Fri, 21 Dec 2018 12:00:10 +0100
parents 1f3fe26f8e3f
children cd0fdfe83217
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -345,10 +345,16 @@ AC_ARG_WITH(view-name, [  --with-view-na
 AC_SUBST(VIEWNAME)
 
 AC_MSG_CHECKING(--with-global-runtime argument)
-AC_ARG_WITH(global-runtime, [  --with-global-runtime=DIR    global runtime directory in 'runtimepath'],
-	AC_MSG_RESULT($withval); AC_DEFINE_UNQUOTED(RUNTIME_GLOBAL, "$withval"),
+AC_ARG_WITH(global-runtime, [  --with-global-runtime=DIR    global runtime directory in 'runtimepath', comma-separated for multiple directories],
+	RUNTIME_GLOBAL="$withval"; AC_MSG_RESULT($withval),
 	AC_MSG_RESULT(no))
 
+if test "X$RUNTIME_GLOBAL" != "X"; then
+  RUNTIME_GLOBAL_AFTER=$(printf -- "$RUNTIME_GLOBAL\\n" | $AWK -F, 'BEGIN { comma=0 } { for (i = NF; i > 0; i--) { if (comma) { printf ",%s/after", $i } else { printf "%s/after", $i; comma=1 } } } END { printf "\n" }')
+  AC_DEFINE_UNQUOTED(RUNTIME_GLOBAL, "$RUNTIME_GLOBAL")
+  AC_DEFINE_UNQUOTED(RUNTIME_GLOBAL_AFTER, "$RUNTIME_GLOBAL_AFTER")
+fi
+
 AC_MSG_CHECKING(--with-modified-by argument)
 AC_ARG_WITH(modified-by, [  --with-modified-by=NAME       name of who modified a release version],
 	AC_MSG_RESULT($withval); AC_DEFINE_UNQUOTED(MODIFIED_BY, "$withval"),