diff src/configure.ac @ 18648:53e66eb23321 v8.1.2316

patch 8.1.2316: FORTIFY_SOURCE can also be present in CPPFLAGS Commit: https://github.com/vim/vim/commit/91b992c38769b343b4a66a5f8e589aa9897fdc9f Author: Bram Moolenaar <Bram@vim.org> Date: Sun Nov 17 19:07:42 2019 +0100 patch 8.1.2316: FORTIFY_SOURCE can also be present in CPPFLAGS Problem: FORTIFY_SOURCE can also be present in CPPFLAGS. Solution: Remove it in configure. (Benedikt Morbach, closes https://github.com/vim/vim/issues/2786)
author Bram Moolenaar <Bram@vim.org>
date Sun, 17 Nov 2019 19:15:03 +0100
parents 2329061e6289
children 9007e9896303
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -3789,7 +3789,7 @@ if test "$enable_canberra" = "yes"; then
      ca_context *hello;
      ca_context_create(&hello);],
        AC_MSG_RESULT(yes); AC_DEFINE(HAVE_CANBERRA),
-       AC_MSG_RESULT(no); CFLAGS="$ac_save_CFLAGS"; LIBS="$ac_save_LIBS")
+       AC_MSG_RESULT(no; try installing libcanberra-dev); CFLAGS="$ac_save_CFLAGS"; LIBS="$ac_save_LIBS")
 fi
 
 
@@ -4482,6 +4482,7 @@ if test "$GCC" = yes; then
   AC_MSG_CHECKING(whether we need -D_FORTIFY_SOURCE=1)
   if test "$gccmajor" -gt "3"; then
     CFLAGS=`echo "$CFLAGS" | sed -e 's/ *-Wp,-D_FORTIFY_SOURCE=.//g' -e 's/ *-D_FORTIFY_SOURCE=.//g' -e 's/ *-U_FORTIFY_SOURCE//g' -e 's/$/ -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1/'`
+    CPPFLAGS=`echo "$CPPFLAGS" | sed -e 's/ *-Wp,-D_FORTIFY_SOURCE=.//g' -e 's/ *-D_FORTIFY_SOURCE=.//g' -e 's/ *-U_FORTIFY_SOURCE//g'`
     AC_MSG_RESULT(yes)
   else
     AC_MSG_RESULT(no)