diff src/configure.in @ 834:5117153003bd v7.0e

updated for version 7.0e
author vimboss
date Sun, 16 Apr 2006 18:30:08 +0000
parents 23f82b5d2814
children 8e5830943bff
line wrap: on
line diff
--- a/src/configure.in
+++ b/src/configure.in
@@ -2668,6 +2668,7 @@ AC_CHECK_LIB(xpg4, _xpg4_setrunelocale, 
 
 dnl Check how we can run ctags
 dnl --version for Exuberant ctags (preferred)
+dnl       Add --fields=+S to get function signatures for omni completion.
 dnl -t for typedefs (many ctags have this)
 dnl -s for static functions (Elvis ctags only?)
 dnl -v for variables. Dangerous, most ctags take this for 'vgrind style'.
@@ -2675,7 +2676,7 @@ dnl -i+m to test for older Exuberant cta
 AC_MSG_CHECKING(how to create tags)
 test -f tags && mv tags tags.save
 if (eval ctags --version /dev/null | grep Exuberant) < /dev/null 1>&AC_FD_CC 2>&1; then
-  TAGPRG="ctags -I INIT+"
+  TAGPRG="ctags -I INIT+ --fields=+S"
 else
   (eval etags	   /dev/null) < /dev/null 1>&AC_FD_CC 2>&1 && TAGPRG="etags"
   (eval etags -c   /dev/null) < /dev/null 1>&AC_FD_CC 2>&1 && TAGPRG="etags -c"