diff src/configure.ac @ 12341:4f1b89fb9f58 v8.0.1050

patch 8.0.1050: terminal window feature not included by default commit https://github.com/vim/vim/commit/595a40226ea1285689b622042534fd8442402db3 Author: Bram Moolenaar <Bram@vim.org> Date: Sun Sep 3 19:15:57 2017 +0200 patch 8.0.1050: terminal window feature not included by default Problem: Terminal window feature not included by default. Solution: Include the terminal feature for the "huge" build.
author Christian Brabandt <cb@256bit.org>
date Sun, 03 Sep 2017 19:30:05 +0200
parents c141c7d8606c
children 20dd08d26680
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2031,16 +2031,26 @@ fi
 AC_MSG_CHECKING(--enable-terminal argument)
 AC_ARG_ENABLE(terminal,
 	[  --enable-terminal       Enable terminal emulation support.],
-	[enable_terminal="yes"], )
-if test "$enable_terminal" = "yes"; then
+	[enable_terminal="yes"], [enable_terminal="auto"])
+if test "$enable_terminal" = "yes" || test "$enable_terminal" = "auto" -a "x$features" = "xhuge" ; then
   if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
     AC_MSG_RESULT([cannot use terminal emulator with tiny or small features])
     enable_terminal="no"
   else
-    AC_MSG_RESULT(yes)
+    if test "$enable_terminal" = "auto"; then
+      enable_terminal="yes"
+      AC_MSG_RESULT(defaulting to yes)
+    else
+      AC_MSG_RESULT(yes)
+    fi
   fi
 else
-  AC_MSG_RESULT(no)
+  if test "$enable_terminal" = "auto"; then
+    enable_terminal="no"
+    AC_MSG_RESULT(defaulting to no)
+  else
+    AC_MSG_RESULT(no)
+  fi
 fi
 if test "$enable_terminal" = "yes"; then
   AC_DEFINE(FEAT_TERMINAL)