diff src/configure.ac @ 25741:412b436f7788 v8.2.3406

patch 8.2.3406: on some systems tests fail without _REENTRANT Commit: https://github.com/vim/vim/commit/3ae5fc9a6a881e0be381e4cc70080ac5908d7520 Author: Bram Moolenaar <Bram@vim.org> Date: Mon Sep 6 18:57:30 2021 +0200 patch 8.2.3406: on some systems tests fail without _REENTRANT Problem: On some systems tests fail without _REENTRANT. (Elimar Riesebieter) Solution: Add -D_REENTRANT in configure. (closes #7402)
author Bram Moolenaar <Bram@vim.org>
date Mon, 06 Sep 2021 19:00:05 +0200
parents 91671fd5c0bd
children 05d1062b1dc0
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4504,6 +4504,12 @@ if test "$MACOS_X" = "yes"; then
   fi
 fi
 
+dnl On some systems REENTRANT needs to be defined.  It should not hurt to use
+dnl it everywhere.
+if `echo "$CFLAGS" | grep -v D_REENTRANT >/dev/null`; then
+  CFLAGS="$CFLAGS -D_REENTRANT"
+fi
+
 dnl gcc 3.1 changed the meaning of -MM.  The only solution appears to be to
 dnl use "-isystem" instead of "-I" for all non-Vim include dirs.
 dnl But only when making dependencies, cproto and lint don't take "-isystem".