diff src/configure.in @ 699:2af8de31a3a8

updated for version 7.0211
author vimboss
date Wed, 01 Mar 2006 22:09:21 +0000
parents f08390485cd3
children 2fae45239fb3
line wrap: on
line diff
--- a/src/configure.in
+++ b/src/configure.in
@@ -164,7 +164,9 @@ if test "`(uname) 2>/dev/null`" = Darwin
     fi
   fi
 
-  dnl avoid a bug with -O2 for intel
+  dnl Avoid a bug with -O2 with gcc 4.0.  Symptom: malloc() reports double
+  dnl free.  This happens in expand_filename(), because the optimizer swaps
+  dnl two blocks of code that use "repl" that can't be swapped.
   if test "$MACARCH" = "intel" -o "$MACARCH" = "both"; then
     CFLAGS=`echo "$CFLAGS" | sed 's/-O[[23456789]]/-Oz/'`
   fi