diff src/configure.ac @ 21520:25cdb1d6585a v8.2.1310

patch 8.2.1310: configure with Xcode 12 fails to check for tgetent Commit: https://github.com/vim/vim/commit/bd7f7c123db58dd7f50f4d1391577686d2f1bcc6 Author: Bram Moolenaar <Bram@vim.org> Date: Tue Jul 28 21:03:37 2020 +0200 patch 8.2.1310: configure with Xcode 12 fails to check for tgetent Problem: Configure with Xcode 12 fails to check for tgetent. Solution: Declare tgetent(). (Ozaki Kiichi, closes https://github.com/vim/vim/issues/6558)
author Bram Moolenaar <Bram@vim.org>
date Tue, 28 Jul 2020 21:15:04 +0200
parents 228a3719c49f
children 13e0857cb114
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -3510,7 +3510,7 @@ fi
 
 if test "x$olibs" = "x$LIBS"; then
   AC_MSG_CHECKING([for tgetent()])
-  AC_TRY_LINK([],
+  AC_TRY_LINK([int tgetent(char *, const char *);],
       [char s[10000]; int res = tgetent(s, "thisterminaldoesnotexist");],
 	AC_MSG_RESULT(yes),
 	AC_MSG_ERROR([NOT FOUND!