diff src/configure.ac @ 15136:1f3fe26f8e3f v8.1.0578

patch 8.1.0578: cannot disable arabic, rightleft and farsi in configure commit https://github.com/vim/vim/commit/5c5697f29829fc3b21fc5452fe8f239f6a4cb8e1 Author: Bram Moolenaar <Bram@vim.org> Date: Wed Dec 12 20:34:09 2018 +0100 patch 8.1.0578: cannot disable arabic, rightleft and farsi in configure Problem: Cannot disable arabic, rightleft and farsi in configure. Solution: Add configur flags. (Diego Fernando Carri?n, closes https://github.com/vim/vim/issues/1867)
author Bram Moolenaar <Bram@vim.org>
date Wed, 12 Dec 2018 20:45:06 +0100
parents 2c72fa16aa70
children 54d2905bd5ab
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2138,6 +2138,45 @@ if test "$enable_multibyte" = "yes"; the
   AC_DEFINE(FEAT_MBYTE)
 fi
 
+dnl Right-to-Left language support for Vim will be included with big features,
+dnl unless ENABLE_RIGHTLEFT is undefined.
+AC_MSG_CHECKING(--disable-rightleft argument)
+AC_ARG_ENABLE(rightleft,
+	[  --disable-rightleft     Do not include Right-to-Left language support.],
+	, [enable_rightleft="yes"])
+if test "$enable_rightleft" = "yes"; then
+	AC_MSG_RESULT(no)
+else
+	AC_MSG_RESULT(yes)
+	AC_DEFINE(DISABLE_RIGHTLEFT)
+fi
+
+dnl Arabic language support for Vim will be included with big features,
+dnl unless ENABLE_ARABIC is undefined.
+AC_MSG_CHECKING(--disable-arabic argument)
+AC_ARG_ENABLE(arabic,
+	[  --disable-arabic        Do not include Arabic language support.],
+	, [enable_arabic="yes"])
+if test "$enable_arabic" = "yes"; then
+	AC_MSG_RESULT(no)
+else
+	AC_MSG_RESULT(yes)
+	AC_DEFINE(DISABLE_ARABIC)
+fi
+
+dnl Farsi language support for vim will be included with big features,
+dnl unless ENABLE_FARSI is undefined.
+AC_MSG_CHECKING(--disable-farsi argument)
+AC_ARG_ENABLE(farsi,
+	[  --disable-farsi         Do not include Farsi language support.],
+	, [enable_farsi="yes"])
+if test "$enable_farsi" = "yes"; then
+	AC_MSG_RESULT(no)
+else
+	AC_MSG_RESULT(yes)
+	AC_DEFINE(DISABLE_FARSI)
+fi
+
 AC_MSG_CHECKING(--enable-hangulinput argument)
 AC_ARG_ENABLE(hangulinput,
 	[  --enable-hangulinput    Include Hangul input support.], ,