diff src/configure.ac @ 22488:16b0eb5fd816 v8.2.1792

patch 8.2.1792: Configure does not recognize Racket 6.1+ Commit: https://github.com/vim/vim/commit/588d241d44fc25ad4c5a635ee4fdeafdfcee0fde Author: Bram Moolenaar <Bram@vim.org> Date: Sat Oct 3 14:24:19 2020 +0200 patch 8.2.1792: Configure does not recognize Racket 6.1+ Problem: Configure does not recognize Racket 6.1+. Solution: Add a check for "rktio". (closes https://github.com/vim/vim/issues/7062)
author Bram Moolenaar <Bram@vim.org>
date Sat, 03 Oct 2020 14:30:05 +0200
parents 2cc0de1e05a6
children 29b2448f2191
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -880,6 +880,9 @@ if test "$enable_mzschemeinterp" = "yes"
 	  MZSCHEME_CFLAGS="-DMZ_PRECISE_GC"
 	elif test -f "${path}/libracket3m.a"; then
 	  MZSCHEME_LIBS="${path}/libracket3m.a"
+	  if test -f "${path}/librktio.a"; then
+	    MZSCHEME_LIBS="${MZSCHEME_LIBS} ${path}/librktio.a"
+	  fi
 	  MZSCHEME_CFLAGS="-DMZ_PRECISE_GC"
 	elif test -f "${path}/libracket.a"; then
 	  MZSCHEME_LIBS="${path}/libracket.a ${path}/libmzgc.a"