diff src/configure.ac @ 16974:15f787b7da56 v8.1.1487

patch 8.1.1487: older msgfmt cannot generate proper .desktop file commit https://github.com/vim/vim/commit/62a88f498ac8d996bc976871cd80fcc14466f013 Author: Bram Moolenaar <Bram@vim.org> Date: Fri Jun 7 20:44:40 2019 +0200 patch 8.1.1487: older msgfmt cannot generate proper .desktop file Problem: Older msgfmt cannot generate proper .desktop file. Solution: Add a configure check to not use this msgfmt version. (Ken Takata)
author Bram Moolenaar <Bram@vim.org>
date Fri, 07 Jun 2019 20:45:06 +0200
parents 7ad3fc329e08
children 353ed7ef78df
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4302,8 +4302,14 @@ if test "$enable_nls" = "yes"; then
       AC_MSG_CHECKING([if msgfmt supports --desktop])
       MSGFMT_DESKTOP=
       if "$MSGFMT" --help | grep -e '--desktop' >/dev/null; then
-	AC_MSG_RESULT([yes])
-	MSGFMT_DESKTOP="gvim.desktop vim.desktop"
+	if "$MSGFMT" --version | grep '0.19.[[3-7]]$' >/dev/null; then
+	  dnl GNU gettext 0.19.7's --desktop is broken.  We assume back to
+	  dnl 0.19.3 is also broken.
+	  AC_MSG_RESULT([broken])
+	else
+	  AC_MSG_RESULT([yes])
+	  MSGFMT_DESKTOP="gvim.desktop vim.desktop"
+	fi
       else
 	AC_MSG_RESULT([no])
       fi