diff src/configure.ac @ 12614:12f4408c7f69 v8.0.1185

patch 8.0.1185: Ruby library includes minor version number commit https://github.com/vim/vim/commit/9202162c5c069c925b6b9bf84e546fbd362cdf46 Author: Bram Moolenaar <Bram@vim.org> Date: Thu Oct 12 12:33:43 2017 +0200 patch 8.0.1185: Ruby library includes minor version number Problem: Ruby library includes minor version number. Solution: Only use the API version number. (Ben Boeckel, closes https://github.com/vim/vim/issues/2199)
author Christian Brabandt <cb@256bit.org>
date Thu, 12 Oct 2017 12:45:07 +0200
parents 55257baece9a
children baf88919c791
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1902,9 +1902,9 @@ if test "$enable_rubyinterp" = "yes" -o 
 	RUBY_PRO="if_ruby.pro"
 	AC_DEFINE(FEAT_RUBY)
 	if test "$enable_rubyinterp" = "dynamic"; then
-	  libruby=`$vi_cv_path_ruby -r rbconfig -e "puts $ruby_rbconfig::CONFIG[['LIBRUBY_SO']]"`
+	  libruby_soname=`$vi_cv_path_ruby -r rbconfig -e "puts $ruby_rbconfig::CONFIG[['LIBRUBY_ALIASES']].split[[0]]"`
 	  AC_DEFINE(DYNAMIC_RUBY)
-	  RUBY_CFLAGS="-DDYNAMIC_RUBY_DLL=\\\"$libruby\\\" -DDYNAMIC_RUBY_VER=$rubyversion $RUBY_CFLAGS"
+	  RUBY_CFLAGS="-DDYNAMIC_RUBY_DLL=\\\"$libruby_soname\\\" -DDYNAMIC_RUBY_VER=$rubyversion $RUBY_CFLAGS"
 	  RUBY_LIBS=
 	fi
       else