diff src/configure.ac @ 27020:0f2dd0d07071 v8.2.4039

patch 8.2.4039: the xdiff library is linked in even when not used Commit: https://github.com/vim/vim/commit/67ffb417861a90fd2c1b215a42fd230272ed94cb Author: Bram Moolenaar <Bram@vim.org> Date: Sat Jan 8 13:36:57 2022 +0000 patch 8.2.4039: the xdiff library is linked in even when not used Problem: The xdiff library is linked in even when not used. Solution: Use configure to decide whether xdiff object files are included.
author Bram Moolenaar <Bram@vim.org>
date Sat, 08 Jan 2022 14:45:03 +0100
parents fccd67ae58c8
children 7d66380a6b86
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -567,6 +567,16 @@ else
   AC_MSG_RESULT(yes)
 fi
 
+AC_MSG_CHECKING([diff feature])
+if test "x$features" = "xtiny" -o "x$features" = "xsmall"; then
+  AC_MSG_RESULT([disabled in $features version])
+else
+  AC_MSG_RESULT(enabled)
+  AC_DEFINE(FEAT_DIFF)
+  XDIFF_OBJS_USED="\$(XDIFF_OBJS)"
+  AC_SUBST(XDIFF_OBJS_USED)
+fi
+
 dnl Check for Lua feature.
 AC_MSG_CHECKING(--enable-luainterp argument)
 AC_ARG_ENABLE(luainterp,