diff src/configure.ac @ 13006:035f78f42953 v8.0.1379

patch 8.0.1379: configure check for selinux does not check for header file commit https://github.com/vim/vim/commit/e4b78e2a42e9030348770764c478b73caa925539 Author: Bram Moolenaar <Bram@vim.org> Date: Thu Dec 7 22:29:11 2017 +0100 patch 8.0.1379: configure check for selinux does not check for header file Problem: Configure check for selinux does not check for header file. Solution: Add an AC_CHECK_HEADER(). (Benny Siegert)
author Christian Brabandt <cb@256bit.org>
date Thu, 07 Dec 2017 22:30:07 +0100
parents 14f287552218
children 0a738ac6189b
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -433,8 +433,9 @@ if test "x$found_smack" = "x"; then
   if test "$enable_selinux" = "yes"; then
     AC_MSG_RESULT(no)
     AC_CHECK_LIB(selinux, is_selinux_enabled,
+	[AC_CHECK_HEADER(selinux/selinux.h,
 	    [LIBS="$LIBS -lselinux"
-	     AC_DEFINE(HAVE_SELINUX)])
+	    AC_DEFINE(HAVE_SELINUX)])])
   else
      AC_MSG_RESULT(yes)
   fi