diff src/configure.ac @ 29534:e491e48757d7 v9.0.0108

patch 9.0.0108: configure check for timer_create may give wrong error Commit: https://github.com/vim/vim/commit/5f6cae8b8a49c435556e32f84d067cd0b4d28e4c Author: Bram Moolenaar <Bram@vim.org> Date: Sat Jul 30 11:00:50 2022 +0100 patch 9.0.0108: configure check for timer_create may give wrong error Problem: Configure check for timer_create may give wrong error. Solution: Give a warning instead of an error.
author Bram Moolenaar <Bram@vim.org>
date Sat, 30 Jul 2022 12:15:07 +0200
parents 1733b6162f75
children 029c59bf78f1
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -3828,7 +3828,7 @@ static void set_flag(union sigval sv) {}
   ])],
   vim_cv_timer_create=yes,
   vim_cv_timer_create=no,
-  AC_MSG_ERROR(cross-compiling: please set 'vim_cv_timer_create')
+  AC_MSG_WARN([failed to build test program; if cross-compiling please set 'vim_cv_timer_create'])
   )])
 
 dnl If the previous failed, check for timer_create() and linking with -lrt.
@@ -3856,7 +3856,7 @@ if test "x$vim_cv_timer_create" = "xno" 
       ])],
       vim_cv_timer_create_with_lrt=yes,
       vim_cv_timer_create_with_lrt=no,
-      AC_MSG_ERROR(cross-compiling: please set 'vim_cv_timer_create_with_lrt')
+      AC_MSG_WARN([failed to build test program; if cross-compiling please set 'vim_cv_timer_create_with_lrt'])
     )])
   LIBS="$save_LIBS"
 else