diff src/configure.ac @ 29446:ef4f17d97ad0 v9.0.0065

patch 9.0.0065: cross-compiling doesn't work because of timer_create check Commit: https://github.com/vim/vim/commit/509695c1c3f5c94bf4b1de5dd0fc11202804f638 Author: Richard Purdie <richard.purdie@linuxfoundation.org> Date: Sun Jul 24 20:48:00 2022 +0100 patch 9.0.0065: cross-compiling doesn't work because of timer_create check Problem: Cross-compiling doesn't work because of timer_create check. Solution: Use AC_CACHE_CHECK(). (Richard Purdie, closes https://github.com/vim/vim/issues/10777)
author Bram Moolenaar <Bram@vim.org>
date Sun, 24 Jul 2022 22:00:03 +0200
parents 653bdd2b1fa1
children e6d788e0c121
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -3807,7 +3807,7 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
 dnl Check for timer_create. It probably requires the 'rt' library.
 dnl Run the program to find out if timer_create(CLOCK_MONOTONIC) actually
 dnl works, on Solaris timer_create() exists but fails at runtime.
-AC_MSG_CHECKING([for timer_create])
+AC_CACHE_CHECK([for timer_create], [vim_cv_timer_create],
 save_LIBS="$LIBS"
 LIBS="$LIBS -lrt"
 AC_RUN_IFELSE([AC_LANG_PROGRAM([
@@ -3824,7 +3824,7 @@ static void set_flag(union sigval sv) {}
   if (timer_create(CLOCK_MONOTONIC, &action, &timer_id) < 0)
     exit(1);  // cannot create a monotonic timer
   ])],
-  AC_MSG_RESULT(yes; with -lrt); AC_DEFINE(HAVE_TIMER_CREATE),
+  AC_MSG_NOTICE(timer_create with -lrt); vim_cv_timer_create=yes,
   LIBS="$save_LIBS"
   AC_RUN_IFELSE([AC_LANG_PROGRAM([
 #include<signal.h>
@@ -3840,8 +3840,16 @@ static void set_flag(union sigval sv) {}
     if (timer_create(CLOCK_MONOTONIC, &action, &timer_id) < 0)
       exit(1);  // cannot create a monotonic timer
     ])],
-    AC_MSG_RESULT(yes); AC_DEFINE(HAVE_TIMER_CREATE),
-    AC_MSG_RESULT(no)))
+    vim_cv_timer_create=yes,
+    vim_cv_timer_create=no),
+    AC_MSG_ERROR(cross-compiling: please set 'vim_cv_timer_create')
+    )
+)
+
+if test "x$vim_cv_timer_create" = "xyes" ; then
+  AC_DEFINE(HAVE_TIMER_CREATE)
+fi
+
 
 AC_CACHE_CHECK([whether stat() ignores a trailing slash], [vim_cv_stat_ignores_slash],
   [