diff src/configure.ac @ 29513:e6d788e0c121 v9.0.0098

patch 9.0.0098: missing include file in timer_create configure check Commit: https://github.com/vim/vim/commit/5748b7f2c8a8e8e6d12b3e2531df5c0261fd8f3b Author: Bram Moolenaar <Bram@vim.org> Date: Thu Jul 28 12:09:04 2022 +0100 patch 9.0.0098: missing include file in timer_create configure check Problem: missing include file in timer_create configure check. Solution: Inlucde stdlib.h.
author Bram Moolenaar <Bram@vim.org>
date Thu, 28 Jul 2022 13:15:03 +0200
parents ef4f17d97ad0
children 1733b6162f75
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -3807,12 +3807,16 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
 dnl Check for timer_create. It probably requires the 'rt' library.
 dnl Run the program to find out if timer_create(CLOCK_MONOTONIC) actually
 dnl works, on Solaris timer_create() exists but fails at runtime.
-AC_CACHE_CHECK([for timer_create], [vim_cv_timer_create],
+AC_CACHE_CHECK([for timer_create], [vim_cv_timer_create], [
 save_LIBS="$LIBS"
 LIBS="$LIBS -lrt"
 AC_RUN_IFELSE([AC_LANG_PROGRAM([
-#include<signal.h>
-#include<time.h>
+#if STDC_HEADERS
+# include <stdlib.h>
+# include <stddef.h>
+#endif
+#include <signal.h>
+#include <time.h>
 static void set_flag(union sigval sv) {}
 ], [
   struct timespec ts;
@@ -3827,6 +3831,10 @@ static void set_flag(union sigval sv) {}
   AC_MSG_NOTICE(timer_create with -lrt); vim_cv_timer_create=yes,
   LIBS="$save_LIBS"
   AC_RUN_IFELSE([AC_LANG_PROGRAM([
+#if STDC_HEADERS
+# include <stdlib.h>
+# include <stddef.h>
+#endif
 #include<signal.h>
 #include<time.h>
 static void set_flag(union sigval sv) {}
@@ -3843,7 +3851,7 @@ static void set_flag(union sigval sv) {}
     vim_cv_timer_create=yes,
     vim_cv_timer_create=no),
     AC_MSG_ERROR(cross-compiling: please set 'vim_cv_timer_create')
-    )
+    )]
 )
 
 if test "x$vim_cv_timer_create" = "xyes" ; then