diff src/configure.ac @ 23792:de74b00b15bb v8.2.2437

patch 8.2.2437: deprecation warnings with default configuration Commit: https://github.com/vim/vim/commit/4d8479b335e92a95b09fdee09309ea0df934cb9e Author: Bram Moolenaar <Bram@vim.org> Date: Sun Jan 31 14:36:06 2021 +0100 patch 8.2.2437: deprecation warnings with default configuration Problem: Deprecation warnings with default configuration. Solution: Add -Wno-deprecated-declarations.
author Bram Moolenaar <Bram@vim.org>
date Sun, 31 Jan 2021 14:45:04 +0100
parents 6a4554de9925
children 17ee19090b85
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -90,7 +90,7 @@ with_x_arg="$with_x"
 dnl Set default value for CFLAGS if none is defined or it's empty
 if test -z "$CFLAGS"; then
   CFLAGS="-O"
-  test "$GCC" = yes && CFLAGS="-O2 -fno-strength-reduce -Wall"
+  test "$GCC" = yes && CFLAGS="-O2 -fno-strength-reduce -Wall -Wno-deprecated-declarations"
 fi
 if test "$GCC" = yes; then
   dnl method that should work for nearly all versions