diff src/configure.in @ 8893:d5d2e48666bd v7.4.1733

commit https://github.com/vim/vim/commit/839e954aaa72ef62f65416d177f829e681c15466 Author: Bram Moolenaar <Bram@vim.org> Date: Thu Apr 14 16:46:02 2016 +0200 patch 7.4.1733 Problem: "make install" doesn't know about cross-compiling. (Christian Neukirchen) Solution: Add CROSS_COMPILING. (closes https://github.com/vim/vim/issues/740)
author Christian Brabandt <cb@256bit.org>
date Thu, 14 Apr 2016 17:00:05 +0200
parents caed4b2d305f
children 53e53aeb35ad
line wrap: on
line diff
--- a/src/configure.in
+++ b/src/configure.in
@@ -88,9 +88,12 @@ fi
 
 dnl If configure thinks we are cross compiling, there might be something
 dnl wrong with the CC or CFLAGS settings, give a useful warning message
+CROSS_COMPILING=
 if test "$cross_compiling" = yes; then
   AC_MSG_RESULT([cannot compile a simple program; if not cross compiling check CC and CFLAGS])
+  CROSS_COMPILING=1
 fi
+AC_SUBST(CROSS_COMPILING)
 
 dnl gcc-cpp has the wonderful -MM option to produce nicer dependencies.
 dnl But gcc 3.1 changed the meaning!  See near the end.