diff src/configure.ac @ 33416:d3bb0db2e0c4 v9.0.1966

patch 9.0.1966: configure prints stray 6 when checking libruby Commit: https://github.com/vim/vim/commit/e379e21ddc2dc12abea9dcfd0708e27788bb568c Author: Illia Bobyr <illia.bobyr@gmail.com> Date: Sat Sep 30 22:59:27 2023 +0200 patch 9.0.1966: configure prints stray 6 when checking libruby Problem: configure prints stray 6 when checking libruby Solution: redirect stdout to dev/null configure: Do not print "6" when checking for libruby `expr` will print the matched string length to the standard output. Current `configure` output looks like this: ``` checking Ruby header files... /usr/include/ruby-3.1.0 6 ``` The script really only cares about `expr` exit code. closes: #13234 Signed-off-by: Christian Brabandt <cb@256bit.org> Co-authored-by: Illia Bobyr <illia.bobyr@gmail.com>
author Christian Brabandt <cb@256bit.org>
date Sat, 30 Sep 2023 23:15:03 +0200
parents b14a47736a1c
children cdf91c682acf
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2077,7 +2077,7 @@ if test "$enable_rubyinterp" = "yes" -o 
 	librubyarg=`$vi_cv_path_ruby -r rbconfig -e "print $ruby_rbconfig.expand($ruby_rbconfig::CONFIG[['LIBRUBYARG']])"`
 	librubya=`$vi_cv_path_ruby -r rbconfig -e "print $ruby_rbconfig.expand($ruby_rbconfig::CONFIG[['LIBRUBY_A']])"`
 	rubylibdir=`$vi_cv_path_ruby -r rbconfig -e "print $ruby_rbconfig.expand($ruby_rbconfig::CONFIG[['libdir']])"`
-	if test -f "$rubylibdir/$librubya" || expr "$librubyarg" : "-lruby"; then
+	if test -f "$rubylibdir/$librubya" || expr "$librubyarg" : "-lruby" >/dev/null; then
 	  RUBY_LIBS="$RUBY_LIBS -L$rubylibdir"
 	elif test "$librubyarg" = "libruby.a"; then
 	  dnl required on Mac OS 10.3 where libruby.a doesn't exist