diff src/configure.ac @ 24301:c5cb45fc82d3 v8.2.2691

patch 8.2.2691: autoconf may mess up compiler flags Commit: https://github.com/vim/vim/commit/3fa5e64e0ed55de718e48d0268edc360b2352bc1 Author: Bram Moolenaar <Bram@vim.org> Date: Fri Apr 2 13:30:59 2021 +0200 patch 8.2.2691: autoconf may mess up compiler flags Problem: Autoconf may mess up compiler flags. Solution: Handle removing FORTIFY_SOURCE a bit better. (Vladimir Lomov, closes #8049)
author Bram Moolenaar <Bram@vim.org>
date Fri, 02 Apr 2021 13:45:03 +0200
parents cdeec1389c8c
children aa4342593469
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4484,8 +4484,8 @@ if test "$GCC" = yes; then
   dnl And undefine it first to avoid a warning.
   AC_MSG_CHECKING(whether we need -D_FORTIFY_SOURCE=1)
   if test "$gccmajor" -gt "3"; then
-    CFLAGS=`echo "$CFLAGS" | sed -e 's/ *-Wp,-D_FORTIFY_SOURCE=.//g' -e 's/ *-D_FORTIFY_SOURCE=.//g' -e 's/ *-U_FORTIFY_SOURCE//g' -e 's/$/ -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1/'`
-    CPPFLAGS=`echo "$CPPFLAGS" | sed -e 's/ *-Wp,-D_FORTIFY_SOURCE=.//g' -e 's/ *-D_FORTIFY_SOURCE=.//g' -e 's/ *-U_FORTIFY_SOURCE//g'`
+    CFLAGS=`echo "$CFLAGS" | sed -e 's/-D_FORTIFY_SOURCE=.,//g' -e 's/,-D_FORTIFY_SOURCE=. //g' -e 's/ *-Wp,-D_FORTIFY_SOURCE=. //g' -e 's/ *-D_FORTIFY_SOURCE=.//g' -e 's/ *-U_FORTIFY_SOURCE//g' -e 's/$/ -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1/'`
+    CPPFLAGS=`echo "$CPPFLAGS" | sed -e 's/-D_FORTIFY_SOURCE=.,//g' -e 's/,-D_FORTIFY_SOURCE=. //g' -e 's/ *-Wp,-D_FORTIFY_SOURCE=. //g' -e 's/ *-D_FORTIFY_SOURCE=.//g' -e 's/ *-U_FORTIFY_SOURCE//g'`
     AC_MSG_RESULT(yes)
   else
     AC_MSG_RESULT(no)