diff src/configure.ac @ 19310:ae6bcbadf04b v8.2.0213

patch 8.2.0213: configure does not recognize gcc 10.0 and later Commit: https://github.com/vim/vim/commit/7077892a7918845a00ce8d7833b43cc6cbed2081 Author: Bram Moolenaar <Bram@vim.org> Date: Wed Feb 5 20:44:24 2020 +0100 patch 8.2.0213: configure does not recognize gcc 10.0 and later Problem: Configure does not recognize gcc 10.0 and later. Solution: Adjust the pattern matching the version number. (Sergei Trofimovich, closes #5580)
author Bram Moolenaar <Bram@vim.org>
date Wed, 05 Feb 2020 20:45:05 +0100
parents 23df4b83fd31
children 224fb493b72c
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2195,7 +2195,7 @@ else
   fi
 
   dnl On my HPUX system the X include dir is found, but the lib dir not.
-  dnl This is a desparate try to fix this.
+  dnl This is a desperate try to fix this.
 
   if test -d "$x_includes" && test ! -d "$x_libraries"; then
     x_libraries=`echo "$x_includes" | sed s/include/lib/`
@@ -4447,7 +4447,7 @@ dnl the number before the version number
 DEPEND_CFLAGS_FILTER=
 if test "$GCC" = yes; then
   AC_MSG_CHECKING(for GCC 3 or later)
-  gccmajor=`echo "$gccversion" | sed -e 's/^\([[1-9]]\)\..*$/\1/g'`
+  gccmajor=`echo "$gccversion" | sed -e 's/^\([[0-9]]\+\)\..*$/\1/g'`
   if test "$gccmajor" -gt "2"; then
     DEPEND_CFLAGS_FILTER="| sed 's+-I */+-isystem /+g'"
     AC_MSG_RESULT(yes)