diff src/configure.ac @ 24675:ae30a87aafd3 v8.2.2876

patch 8.2.2876: configure cannot detect Python 3.10 Commit: https://github.com/vim/vim/commit/23c0192166760b0d73bd39252ca72e3cfe596f6e Author: Bram Moolenaar <Bram@vim.org> Date: Fri May 21 11:43:58 2021 +0200 patch 8.2.2876: configure cannot detect Python 3.10 Problem: Configure cannot detect Python 3.10. Solution: Use sys.version_info. (closes https://github.com/vim/vim/issues/8233)
author Bram Moolenaar <Bram@vim.org>
date Fri, 21 May 2021 11:45:03 +0200
parents 7b48e331519d
children db4afe19285d
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1436,7 +1436,7 @@ if test "$enable_python3interp" = "yes" 
     dnl -- get its version number
     AC_CACHE_CHECK(Python version,vi_cv_var_python3_version,
     [[vi_cv_var_python3_version=`
-          ${vi_cv_path_python3} -c 'import sys; print(sys.version[:3])'`
+          ${vi_cv_path_python3} -c 'import sys; print("{}.{}".format(sys.version_info.major, sys.version_info.minor))'`
     ]])
 
     dnl -- it must be at least version 3