diff src/configure.in @ 7743:6069f43cea4e v7.4.1169

commit https://github.com/vim/vim/commit/e0874f8cbcddfcf9965a85ba35199964efb1d01a Author: Bram Moolenaar <Bram@vim.org> Date: Sun Jan 24 20:36:41 2016 +0100 patch 7.4.1169 Problem: The socket I/O is intertwined with the netbeans code. Solution: Start refactoring the netbeans communication to split off the socket I/O. Add the +channel feature.
author Christian Brabandt <cb@256bit.org>
date Sun, 24 Jan 2016 20:45:05 +0100
parents 6157052a0e58
children 3a1b60f5e89b
line wrap: on
line diff
--- a/src/configure.in
+++ b/src/configure.in
@@ -1938,10 +1938,30 @@ AC_ARG_ENABLE(netbeans,
 	, [enable_netbeans="yes"])
 if test "$enable_netbeans" = "yes"; then
   AC_MSG_RESULT(no)
+else
+  AC_MSG_RESULT(yes)
+fi
+
+AC_MSG_CHECKING(--disable-channel argument)
+AC_ARG_ENABLE(channel,
+	[  --disable-channel      Disable process communication support.],
+	, [enable_channel="yes"])
+if test "$enable_channel" = "yes"; then
+  AC_MSG_RESULT(no)
+else
+  if test "$enable_netbeans" = "yes"; then
+    AC_MSG_RESULT(yes, netbeans also disabled)
+    enable_netbeans="no"
+  else
+    AC_MSG_RESULT(yes)
+  fi
+fi
+
+if "$enable_channel" = "yes"; then
   dnl On Solaris we need the socket and nsl library.
   AC_CHECK_LIB(socket, socket)
   AC_CHECK_LIB(nsl, gethostbyname)
-  AC_MSG_CHECKING(whether compiling netbeans integration is possible)
+  AC_MSG_CHECKING(whether compiling with process communication is possible)
   AC_TRY_LINK([
 #include <stdio.h>
 #include <stdlib.h>
@@ -1967,9 +1987,7 @@ if test "$enable_netbeans" = "yes"; then
 		  (void)connect(1, (struct sockaddr *)&server, sizeof(server));
 	    ],
 	AC_MSG_RESULT(yes),
-	AC_MSG_RESULT(no); enable_netbeans="no")
-else
-  AC_MSG_RESULT(yes)
+	AC_MSG_RESULT(no); enable_netbeans="no"; enable_channel="no")
 fi
 if test "$enable_netbeans" = "yes"; then
   AC_DEFINE(FEAT_NETBEANS_INTG)
@@ -1978,6 +1996,13 @@ if test "$enable_netbeans" = "yes"; then
   NETBEANS_OBJ="objects/netbeans.o"
   AC_SUBST(NETBEANS_OBJ)
 fi
+if test "$enable_channel" = "yes"; then
+  AC_DEFINE(FEAT_CHANNEL)
+  CHANNEL_SRC="channel.c"
+  AC_SUBST(CHANNEL_SRC)
+  CHANNEL_OBJ="objects/channel.o"
+  AC_SUBST(CHANNEL_OBJ)
+fi
 
 AC_MSG_CHECKING(--enable-sniff argument)
 AC_ARG_ENABLE(sniff,