diff src/configure.in @ 5114:56bc3698f8c6 v7.3.1300

updated for version 7.3.1300 Problem: Mac: tiny and small build fails. Solution: Don't include os_macosx.m in tiny build. Include mouse support in small build. (Kazunobu Kuriyama)
author Bram Moolenaar <bram@vim.org>
date Wed, 03 Jul 2013 19:52:53 +0200
parents 9f7b92f232d3
children a4e08386a6aa
line wrap: on
line diff
--- a/src/configure.in
+++ b/src/configure.in
@@ -3698,6 +3698,13 @@ if test "x$MACOSX" = "xyes"; then
   else
     AC_MSG_RESULT(no)
   fi
+  dnl As mentioned above, tiny build implies os_macosx.m isn't needed.  
+  dnl Exclude it from OS_EXTRA_SRC so that linker won't complain about
+  dnl missing Objective-C symbols.
+  if test "x$features" = "xtiny"; then
+    OS_EXTRA_SRC=`echo "$OS_EXTRA_SRC" | sed -e 's+os_macosx.m++'`
+    OS_EXTRA_OBJ=`echo "$OS_EXTRA_OBJ" | sed -e 's+objects/os_macosx.o++'`
+  fi
 fi
 if test "x$MACARCH" = "xboth" && test "x$GUITYPE" = "xCARBONGUI"; then
   LDFLAGS="$LDFLAGS -isysroot $DEVELOPER_DIR/SDKs/MacOSX10.4u.sdk -arch i386 -arch ppc"