diff src/configure.ac @ 33056:3db1758e3268 v9.0.1816

patch 9.0.1816: configure: sed uses non-portable regex Commit: https://github.com/vim/vim/commit/bddc6adca647f7f20ff6e1b7913e394d09c5eb23 Author: ichizok <gclient.gaap@gmail.com> Date: Tue Aug 29 20:54:32 2023 +0200 patch 9.0.1816: configure: sed uses non-portable regex Problem: configure: sed uses non-portable regex Solution: use '*' modifier instead of '\?' in regex for luajit version detection closes: #12954 Signed-off-by: Christian Brabandt <cb@256bit.org> Co-authored-by: ichizok <gclient.gaap@gmail.com>
author Christian Brabandt <cb@256bit.org>
date Tue, 29 Aug 2023 21:00:03 +0200
parents 50e7d33c40f9
children 3b2896d7438f
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -638,7 +638,7 @@ if test "$enable_luainterp" = "yes" -o "
       if test "X$vi_cv_path_luajit" != "X"; then
 	dnl -- find LuaJIT version
 	AC_CACHE_CHECK(LuaJIT version, vi_cv_version_luajit,
-       [ vi_cv_version_luajit=`${vi_cv_path_luajit} -v 2>&1 | sed 's/LuaJIT \([[0-9.]]*\)\.[[0-9]]\(-\?[[a-z0-9]]*\)* .*/\1/'` ])
+       [ vi_cv_version_luajit=`${vi_cv_path_luajit} -v 2>&1 | sed 's/LuaJIT \([[0-9.]]*\)\.[[0-9]]\(-*[[a-z0-9]]*\)* .*/\1/'` ])
 	AC_CACHE_CHECK(Lua version of LuaJIT, vi_cv_version_lua_luajit,
 	[ vi_cv_version_lua_luajit=`${vi_cv_path_luajit} -e "print(_VERSION)" | sed 's/.* //'` ])
 	vi_cv_path_lua="$vi_cv_path_luajit"