diff src/configure.in @ 5409:38a755adc580 v7.4.055

updated for version 7.4.055 Problem: Mac: Where availability macros are defined depends on the system. Solution: Add a configure check. (Felix B?nemann)
author Bram Moolenaar <bram@vim.org>
date Sat, 02 Nov 2013 21:04:38 +0100
parents 31c9acfeda8f
children 739074bdceb8
line wrap: on
line diff
--- a/src/configure.in
+++ b/src/configure.in
@@ -206,6 +206,10 @@ if test "`(uname) 2>/dev/null`" = Darwin
     dnl TODO: use -arch i386 on Intel machines
     CPPFLAGS="$CPPFLAGS -DMACOS_X_UNIX -no-cpp-precomp"
 
+    dnl Mac OS X 10.9+ no longer include AvailabilityMacros.h in Carbon
+    dnl so we need to include it to have access to version macros.
+    AC_CHECK_HEADER(AvailabilityMacros.h, [AC_DEFINE(HAVE_AVAILABILITYMACROS_H, 1, [ Define if we have AvailabilityMacros.h on Mac OS X ])])
+
     dnl If Carbon is found, assume we don't want X11
     dnl unless it was specifically asked for (--with-x)
     dnl or Motif, Athena or GTK GUI is used.