diff src/configure.ac @ 19040:314517a3a0f8 v8.2.0080

patch 8.2.0080: globals using INIT4() are not in the tags file Commit: https://github.com/vim/vim/commit/509ff0688df557155feb7312a0129428eb5d8fc1 Author: Bram Moolenaar <Bram@vim.org> Date: Thu Jan 2 22:38:49 2020 +0100 patch 8.2.0080: globals using INIT4() are not in the tags file Problem: Globals using INIT4() are not in the tags file. Solution: Adjust the tags command.
author Bram Moolenaar <Bram@vim.org>
date Thu, 02 Jan 2020 22:45:03 +0100
parents df141c730008
children 23df4b83fd31
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4236,11 +4236,11 @@ dnl -i+m to test for older Exuberant cta
 AC_MSG_CHECKING(how to create tags)
 test -f tags && mv tags tags.save
 if (eval ctags --version /dev/null | grep Exuberant) < /dev/null 1>&AC_FD_CC 2>&1; then
-  TAGPRG="ctags -I INIT+ --fields=+S"
+  TAGPRG="ctags -I INIT+,INIT2+,INIT3+,INIT4+,INIT5+ --fields=+S"
 elif (eval exctags --version /dev/null | grep Exuberant) < /dev/null 1>&AC_FD_CC 2>&1; then
-  TAGPRG="exctags -I INIT+ --fields=+S"
+  TAGPRG="exctags -I INIT+,INIT2+,INIT3+,INIT4+,INIT5+ --fields=+S"
 elif (eval exuberant-ctags --version /dev/null | grep Exuberant) < /dev/null 1>&AC_FD_CC 2>&1; then
-  TAGPRG="exuberant-ctags -I INIT+ --fields=+S"
+  TAGPRG="exuberant-ctags -I INIT+,INIT2+,INIT3+,INIT4+,INIT5+ --fields=+S"
 else
   TAGPRG="ctags"
   (eval etags	   /dev/null) < /dev/null 1>&AC_FD_CC 2>&1 && TAGPRG="etags"