diff src/configure.ac @ 22095:2cc0de1e05a6 v8.2.1597

patch 8.2.1597: the channel source file is too big Commit: https://github.com/vim/vim/commit/8b5866ded6036f7adece26b6d16962bbd2d47842 Author: Bram Moolenaar <Bram@vim.org> Date: Sat Sep 5 15:48:51 2020 +0200 patch 8.2.1597: the channel source file is too big Problem: The channel source file is too big. Solution: Move job related code to a new source file.
author Bram Moolenaar <Bram@vim.org>
date Sat, 05 Sep 2020 16:00:04 +0200
parents f55cba26348f
children 16b0eb5fd816
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2143,9 +2143,9 @@ if test "$enable_netbeans" = "yes"; then
 fi
 if test "$enable_channel" = "yes"; then
   AC_DEFINE(FEAT_JOB_CHANNEL)
-  CHANNEL_SRC="channel.c"
+  CHANNEL_SRC="job.c channel.c"
   AC_SUBST(CHANNEL_SRC)
-  CHANNEL_OBJ="objects/channel.o"
+  CHANNEL_OBJ="objects/job.o objects/channel.o"
   AC_SUBST(CHANNEL_OBJ)
 fi