diff src/configure.in @ 8194:265bcedffc15 v7.4.1390

commit https://github.com/vim/vim/commit/33c31d5abf122806a4a1b4353e5bdc1dbb9468c0 Author: Bram Moolenaar <Bram@vim.org> Date: Mon Feb 22 21:07:06 2016 +0100 patch 7.4.1390 Problem: When building with GTK and glib-compile-resources cannot be found building Vim fails. (Michael Gehring) Solution: Make GLIB_COMPILE_RESOURCES empty instead of leaving it at "no". (nuko8, closes #655)
author Christian Brabandt <cb@256bit.org>
date Mon, 22 Feb 2016 21:15:05 +0100
parents e90a16795c74
children 3456e2ebebd4
line wrap: on
line diff
--- a/src/configure.in
+++ b/src/configure.in
@@ -2610,17 +2610,18 @@ if test "x$GUITYPE" = "xGTK"; then
     gdk_pixbuf_version_minor=`echo $gdk_pixbuf_version | \
       sed -e 's/[[0-9]][[0-9]]*\.\([[0-9]][[0-9]]*\)\.[[0-9]][[0-9]]*/\1/'`
     if test "x$gdk_pixbuf_version_minor" != x -a \
-      $gdk_pixbuf_version_minor -ge 31 ; then
+	$gdk_pixbuf_version_minor -ge 31 ; then
       AC_MSG_RESULT([OK.])
       AC_PATH_PROG(GLIB_COMPILE_RESOURCES,[glib-compile-resources],no)
       AC_MSG_CHECKING([glib-compile-resources])
       if test "x$GLIB_COMPILE_RESOURCES" = xno ; then
-        AC_MSG_RESULT([cannot be found in PATH.])
+	GLIB_COMPILE_RESOURCES=""
+	AC_MSG_RESULT([cannot be found in PATH.])
       else
 	AC_MSG_RESULT([usable.])
-        AC_DEFINE(USE_GRESOURCE)
-        GRESOURCE_SRC="auto/gui_gtk_gresources.c"
-        GRESOURCE_OBJ="objects/gui_gtk_gresources.o"
+	AC_DEFINE(USE_GRESOURCE)
+	GRESOURCE_SRC="auto/gui_gtk_gresources.c"
+	GRESOURCE_OBJ="objects/gui_gtk_gresources.o"
       fi
     else
       AC_MSG_RESULT([not usable.])