diff src/configure.ac @ 19340:224fb493b72c v8.2.0228

patch 8.2.0228: configure does not recognize gcc version on BSD Commit: https://github.com/vim/vim/commit/348808f7c000a49d435c15db68c814b026f8167d Author: Bram Moolenaar <Bram@vim.org> Date: Fri Feb 7 20:50:07 2020 +0100 patch 8.2.0228: configure does not recognize gcc version on BSD Problem: Configure does not recognize gcc version on BSD. Solution: Do not use "\+" in the pattern matching the version number. (Ozaki Kiichi, closes #5590)
author Bram Moolenaar <Bram@vim.org>
date Fri, 07 Feb 2020 21:00:04 +0100
parents ae6bcbadf04b
children 22f0dda71638
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -4447,7 +4447,7 @@ dnl the number before the version number
 DEPEND_CFLAGS_FILTER=
 if test "$GCC" = yes; then
   AC_MSG_CHECKING(for GCC 3 or later)
-  gccmajor=`echo "$gccversion" | sed -e 's/^\([[0-9]]\+\)\..*$/\1/g'`
+  gccmajor=`echo "$gccversion" | sed -e 's/^\([[1-9]][[0-9]]*\)\..*$/\1/g'`
   if test "$gccmajor" -gt "2"; then
     DEPEND_CFLAGS_FILTER="| sed 's+-I */+-isystem /+g'"
     AC_MSG_RESULT(yes)